
 

iPhoto is the photo management application included in the iLife suite. With iLife ’08, iPhoto 
adds an Events feature that automatically organizes photos according to the dates when they’re 
taken. iPhoto includes a number of advanced image editing features that will allow you to fix 
problems with your photos. It also lets you create slideshows that can be shared with friends 
and relatives, as well as photo books, greeting cards and calendars. You can even add 
background music from your iTunes library to your slideshows, showing the high level of 
integration between all iLife applications. 

The iPhoto Interface
1. Source List - includes the Library, where all 

imported photos and movie clips are stored, 
and shows all of the folders, albums, 
slideshows, and books you’ve created. 

2. Viewing Area - displays the photos in your 
library, albums, slideshows, and books. 

3. Information Pane - shows information about 
your photos, such as the date taken, size, any 
keywords you’ve associated with them, and 
star ratings.

4. Toolbar - includes buttons that allow you to 
organize, edit, and share your photos.
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Importing 
To transfer photos from your camera so 
you can edit and organize them in iPhoto: 
1. Connect your digital camera to your 

Mac using a USB cable. Turn the 
camera on and set it to the correct 
mode for playback (this will vary by 
model so you may have to consult 
your camera’s manual). 

2. iPhoto should open in Import mode 
and show you thumbnails of the 
photos in your camera in the Viewing 
area. Your camera should also be 
listed under Devices on the left side of 
the window.

3. Provide an Event name that describes 
the group of photos you’re about to 
import (My Wedding, etc.).

4. Enter a description for the group of 
photos in the Decription field. 

5. Check the box next to Autosplit events 
if you took photos on separate days 
and want iPhoto to automatically 
create an Event for each day. 

6. If you have previously imported some 
of the photos on the camera, check 
the box next to Hide photos already 
imported. This will show you only the 
new photos in the Import window..

7. Click on Import All to import all of the 
photos on your camera, or on Import 
Selected to import only a few photos 
(you can hold down the Command 
key to select individual photos, or the 
Shift key to select a range of photos).

8. Click on Last Import on the left side to 
view the photos you just imported.

You can also import photos from a CD, 
hard drive, or folder on your computer by 
choosing File > Import to Library.

Viewing
To view your photos:
1. Click on Photos or Events in the 

Source List that appears on the left 
side of the iPhoto window. Thumbnails 
of the photos (or Events) will be 
displayed on the right.

2. iPhoto automatically organizes your 
photos by year in the Source list. To 
view all of the photos taken in a 
particular year, click on that year in 
the Source list on the left (or click on 
Last 12 Months to view photos taken 
during the last year). 

3. Use the zoom slider on the lower right 
to resize the thumbnails and change 
the number of thumbnails that fit in the 
window.

4. Select View > Titles, Rating, or 
Keywords to display additional 
information below the thumbnails (in 
Photos view only). 

5. To Flag photos (such as ones that 
need editing), select the photos you 
want to flag and click on the Flag 
button in the toolbar.

6. To hide photos, select the photos you 
want to hide and click on the Hide 
button in the toolbar0. This will hide 
the photos without deleting them. 

7. To show these hidden photos again, 
select View > Hidden Photos . The 
hidden photos will be marked with an 
X. To unhide the hidden photos, select 
the photos and click on the Unhide 
button.

8. To sort your photos, choose View > 
Sort Photos, then select your sorting 
optiions including the order of the sort 
(Ascending or Descending).

9. To view the photos organized by 
Event, choose View > Event Titles.

10.To change options for how your 
thumbnails are displayed 
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(background, drop shadow, etc.) 
select the Appearance tab in the 
iPhoto preferences (choose iPhoto > 
Preferences).
   

Events
A new option in iPhoto ‘08 is the Events 
view, which organizes photos according 
to when they were taken. To view your 
photos organized by Event:
1. Click on Events in the 

Source list on the left side 
of the window (under 
Library).

2. Hover over one of the thumbnails. A 
number under the thumbnail will let 
you know how many photos are in 
that Event. 

3. Move the cursor to the left or right 
while you’re over the thumbnail. This 
will scrub through the Event so you 
can see the images inside of it.

4. To change the photo used for the 
Event’s thumbnail, right-click or 
control-click on the thumbnail and 
choose Make Key Photo.

5. To split an Event, double-click on it to 
open it, select the photo where you 
want the new Event to start, and click 
on the Split button. Enter a name for 
the new Event by double-clicking on 
the Event name and entering your 
own text.

6. To merge two events, hold down the 
Shift key as you click on each Event’s 
key photo, then click on the Merge 
button in the toolbar.

7. While inside an Event, you can hide, 
rotate and flag photos as described in 
the previous section.

8. To get a quick preview of a photo, 
double-click on it. To close the 
preview, click anywhere on the black 
border and this will return you to 
thumbnail view.  

9. To close an Event and 
return to the Events view, 
click on the All Events button at the 
top. 

Full Screen Mode
To open a photo in full screen mode:
1. Select the photo and click on the full 

screen button at the bottom of the 
Source list. The photo will fill your 
entire screen. 

2. To move to another photo while in full 
screen view, move your cursor toward 
the top of the screen until the photo 
browser appears, then click on a 
different photo.

3. To zoom in, move your cursor toward 
the bottom of the screen to display the 
toolbar, then use the zoom slider in 
the lower right. As you drag the slider 
a Navigation window will be displayed 
if the photo is larger than the screen. 
You can move to a different part of the 
zoomed in photo by dragging the 
small square inside the Navigation 
window.

4. To edit the photo, click on one of the 
editing buttons in the toolbar.

5. Click on the Info button while the 
editing toolbar is displayed to add a 
title, description, and rating by using 
the fields in the Information popup 
window.

6. Use the Compare button to view two 
photos side by side. You can use this 
feature to compare different versions 
of photos. 

7. To exit full screen mode, click on the X 
in the lower right corner or press the 
Escape key on your keyboard. 
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Organizing with Albums 
To organize a set of photos into a new 
album: 
1. Choose File > New Album (or click on 

the plus button near the bottom left 
corner of the iPhoto window).

2. Select Album in the popup window 
and provide a name for your album.

3. Click on Create. 
4. To add photos to the new album, click 

on Library and then drag photos from 
the display area on the right to the 
new album shown in the Source list 
on the left. 

 
There are other ways to create an album: 
a. select a few photos and then choose 

File > New Album from Selection.
b. Drag a folder of photos from a Finder 

window into the Source list. 
c. Select File > New Smart Album. A 

Smart Album contains photos 
matching criteria you specify.

 
To delete an album, right-click or Control-
click on it in the Source list and choose 
Delete album. This will only delete the 
album, not the photos inside of it.

Ratings and Keywords
iPhoto allows you to tag your photos 
using ratings and keywords:

Ratings
To assign a rating to a photo:
1. Select the photo you want rate in the 

display area on the right.
2. Right-click (or control-click) and select 

My Rating. 
3. Assign a rating based on 

the number of stars.
4. Choose View > Rating to 

show the number of stars 
underneath each 
thumbnail.

5. To sort your photos by rating, select 
View > Sort Photos > By Rating.  

Keywords
Keywords are labels you can use to find 
photos in a specific category. To assign 
keywords to a set of photos:
1. Select the photos you want to assign 

keywords to in the main display area.
2. Choose Window > Show Keywords to 

open the Keywords window.
3. Select the keywords you want to 

assign to the photo by clicking to 
select them. To remove keywords, 
click on them again to deselect them. 

4. To add new keywords to your list of 
available keywords, click on Edit 
Keywords in the Keywords window, 
then click on the plus button and enter 
the name of the new keyword. 

To display only the photos that have a 
specific keyword assigned to them, type 
in the keyword in the Search box at the 
bottom of the iPhoto window.

Editing 
iPhoto provides some basic editing 
features. iPhoto supports non-destructive 
editing. When you open a photo for 
editing, iPhoto automatically creates a 
copy of it. You can return to the original 
version at any time by choosing Photos > 
Revert to Original. To undo just the last 
change, choose Edit > Undo or use the 
keyboard shortcut Command + Z.    

To edit a photo, select its thumbnail and 
click on the Edit button in the toolbar at 
the bottom of the display area. In Edit 
mode, iPhoto will display a toolbar at the 
bottom of the window with the following 
options (from left to right):  

• Rotate: Changes the orientation of a 
photo. By default, the photo will be 
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rotated counter-clockwise. To rotate it in 
a clockwise direction, hold the Option 
button before you click on the Rotate 
button. 

• Crop: Removes unwanted areas of a 
photo to improve composition. To crop a 
photo: 

1. Click on the Crop button.
2. Resize the bounding box to cover 

the area of the photo you wish to 
keep. You can also drag the box to 
repositiion it. As you drag, a grid 
will be displayed to help you keep 
to the “rule of thirds”. You should 
try to keep the focal point of your 
composition (such as eyes in a 
portrait) near one of the 
intersections in the grid.

3. To constrain dimensions to a 
preset size, click on the Contrain 
box and choose one of the preset 
sizes using the pulldown menu.

4. Click on Apply to save your 
changes.

• Straighten: Displays a grid that allows 
you to align of a photo using the slider 
in the overlay.

• Enhance: iPhoto automatically fixes the 
colors and contrast of a photo.

• Red Eye: Reduces the “red-eye” effect 
created by the camera’s flash. To 
remove red-eye:

1. Click on the Red Eye button.
2. Click on each eye using the 

crosshairs. 
3. Click on the Red Eye button again 

after you’ve done both eyes. 
4. Click on Done to save your 

changes The red eye feature 
replaces the red in your subject’s 
eyes with a neutral gray.

• Retouch: Removes blemishes, 
scratches and other damage from 
photos. To remove a blemish or scratch:

1. Click on the Retouch button.

2. Use the Size slider to change the 
size of the brush used to remove 
the blemish or scratch.

3. Click on the area of the picture you 
want to fix with the Retouch brush. 
It helps to change the zoom level 
when you use the Retouch tool.

4. When you’re done fixing the 
picture, click on the Retouch 
button again, then on Done. 

• One Click Effects: Converts a picture 
into black and white or adds a special 
effect such as a sepia tone. To use 
these effects:

1. Click on the Effects button to open 
the Effects window. 

2. Select the effect you want to apply 
to your photo. Some effects have 
controls that allow you to change 
the strength of the effect.

3. To undo the effect, click on the 
Original button in the center of the 
Effects window.

4. Click on Done to save your 
changes.

The Adjust Window 
The Adjust window (which will open when 
you click on the Adjust button) includes 
more advanced settings for adjusting the 
tonality, color, and sharpness of your 
image: 
• The histogram at the top of the window 

shows you the distribution of light and 
dark tones in your photo. 

The three sliders underneath the 
histogram can be used to adjust the 
highlights, shadows, and midtones 
indepently of each other. To add 
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highlights, drag the right slider inward. 
To add shadows, drag the left slider 
inward. The middle slider adjusts the 
midtones.  

• Exposure/Contrast: The exposure slider 
lightens or darkens the image across its 
entire tonal range. The contrast slider 
increases contrast by adjusting both the 
dark and light tones at the same time.

• Highlights/Shadows: The highlights 
slider increases detail in the highlights, 
while the shadows slider increases 
detail in the shadows.

• Saturation/Temperature/Tint: These 
three sliders allow you to adjust the 
colors in the image. The eyedropper 
tool allows you to remove a color cast 
by clicking on a neutral gray or white 
point in your photo.

• Sharpness/Reduce Noise: The 
sharpness slider allows you to change 
the focus of the photo, while the 
Reduce Noise slider can be used to 
remove graininess from a photo. This 
slider can be used to remove wrinkles 
by smoothing out skin.

The sliders in the Adjust window can be 
used in two ways:
• by moving the slider, or 
• by clicking on the small button on either 

side of the slider. 

If you don’t like the adjustments you’ve 
made and want to start over, click on the 
Reset button. This will reset all of the 
sliders to their original settings. You can 
also copy settings from one photo to 
another by using the Copy and Paste 
buttons at the bottom of the Adjust 
window.  

Slideshows 
To display your photos in a slideshow: 
1. Select the photos you want to include 

in your slideshow and choose File > 
New Album.

2. Click on the Slideshow tab at the top 
of the dialog box.

3. Check the box next to Use selected 
items in new slideshow. 

4. Enter a name for the slideshow and 
click on Create. iPhoto will switch to 
the Slideshow view. 

5. Click on the Music button to open a 
window where you can select 
background music for your slideshow.

6. Select any song from your iTunes 
library or one created in Garageband 
and use the Play button to hear a 
preview.

7. Make sure Play music during 
slideshow is checked and click on OK 
to add the song to the slideshow. 

8. Click on the Settings button to set the 
options for the slideshow. 

9. Enter the number of seconds you 
want each slide to display on the 
screen in the field at the top of the 
window.

10.Select a transition from the pulldown 
menu and use the slider to set its 
speed.

11.Use the checkboxes in the middle of 
the window to set other options. You 
can choose to display navigation 
controls, titles, and any ratings you 
have assigned. 

12.Select whether you want iPhoto to 
loop the background music, or to 
automatically adjust the duration of 
the slideshow so that it matches the 
duration of a song.

13.Choose a Slideshow Format. You 
should choose 4:3 iDVD, TV if you are 
going to play the slideshow on a TV.

14.Click on OK to set the slideshow 
options.
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You can change the options for an 
individual slide by selecting it and using 
the controls at the bottom of the 
Slideshow window (Effect, Transition, 
Ken Burns Effect). To play your 
slideshow, click on the Play button (or 
click on Preview to get a quick preview).

To export your slideshow as a Quicktime 
movie you can post online:
1. Select the slideshow you want to 

export in the Source List and choose 
File > Export. 

2. Next, enter a file name for your movie 
file, and select from one of the preset 
sizes (small, medium, and large). 

3. Click on Export to save your movie to 
your hard drive. 

Sharing
iPhoto gives you many ways of sharing 
your photos with friends and relatives.  
 
Email
To email photos as 
attachments: 
1. Select the photos you want to send. 
2. Click on the Email button or choose 

Share > Email. 
3. Select a size for your photos from the 

pulldown menu. iPhoto will show you 
how many photos you have selected 
and how big the attachment will be.

4. You can select to include titles and 
comments by using the two 
checkboxes.

5. Click on Compose and Mail will open 
ready for you to address your email. 

 
Web Gallery
To share your photos as a Web Gallery 
using your .Mac account:
1. Select an album in the Source list and 

choose Share > Web Gallery (or 
click on the Web Gallery button 
in the toolbar).

2. Click on Sign In to access your .Mac 
account.

3. Choose who can view the Web 
Gallery by using the pulldown menu.

4. Check the box next to Show photo 
titles if you want to display photo titles 
underneath each thumbnail in the 
Web Gallery.

5. Choose what you want your visitors to 
be able to do on your Web Gallery 
using the check boxes (download 
photos, upload photos, etc.).

6. Click on Publish to upload the photos 
to your .Mac account and display 
them as a Web Gallery.

7. The address of your website will be 
displayed as a link at the top of the 
iPhoto window. Click on the link to 
view your Web Gallery in your default 
web browser.

8. The published Web Gallery will be 
listed in the Source List. You can edit 
the photos in the Web Gallery just as 
you would those in any album. When 
you’re done editing, click on the icon 
next to the gallery’s name to update 
the photos on the .Mac servers.

The Web Gallery feature of .Mac uses 
RSS (the same technology behind 
podcasts) to allow visitors to subscribe to 
your photos. When they click on the 
Subscribe button on the gallery’s web 
page, the gallery will be listed under 
Subscriptions in the Source List. They 
can see updated photos by clicking on 
the update icon next to the gallery’s name 
in the Source List. 
  
iWeb Page or Blog Entry
To create a photos page with iWeb: 
1. Choose Share > Send to iWeb > 

Photo Page (or click on the iWeb 
button in the toolbar). 
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2. When iWeb opens, select a theme 
from the list displayed on the left and 
click on Choose.

3. Change any of the placeholder text on 
your photos page by double-clicking 
to select it and entering new text in its 
place.

4. Once you’re happy with the look of 
your web page, select File > Publish 
to .Mac to connect to your .Mac 
account. To publish your site to a 
folder on your computer, select File > 
Publish to a Folder. You can then use 
an FTP or SSH program to upload this 
folder to any web hosting provider.

You can also choose Share > Send to 
iWeb > Blog to create a new blog entry 
that includes the photos.
 
Network Sharing
iPhoto also allows you to share your 
photos over a network connection. To 
share your photos with people on the 
same network you must change your 
iPhoto preferences:
1. Select iPhoto > Preferences, then 

click on the Sharing tab
2. Check the box next to Share my 

photos. You can share your entire 
library or only selected albums. You 
can also assign a password if you 
only want certain people on the 
network to access your shared 
photos. 

3. Check the box next to Look for shared 
photos to access photos other people 
have shared on the network (they will 
be listed in the Source list along with 
your other albums).

Printing
To print photos:
1. Select the photos you want to print 

and choose File > Print (or click on 
the Print button in the toolbar).

2. Choose a theme from the list on the 
left. A preview will be displayed to the 
right of the list. 

3. Choose the correct printer, the paper 
size, and the print size.

4. Click on Customize to open the 
photos in Print View. The changes you 
make in this view will only affect the 
printed version of the photos. They 
will not affect the version in your 
iPhoto library. A Printing icon will be 
displayed in the Source List until 
you’re finished with your printing 
project.

5. Choose a theme, background, border, 
and layout using the buttons in the 
toolbar while you’re in Print View. 
Some of the layouts include caption 
text. To edit the placeholder text, click 
on it to select it and replace it with 
your own text. Click on Settings if you 
need to change font options.

6. Click on Print at the bottom of the 
Print View window.

7. Enter the number of copies you want 
to print and click on Print. If you want 
to save a PDF version, click on PDF 
and choose Save as PDF.

Ordering Prints
To order prints of your photos from 
Kodak:
1. Select the photos you would like to 

order prints of and click the Order 
Prints button (or select Share > Order 
Prints).

2. In the Order Prints window, select the 
number of copies for each size that 
you want to order. An exclamation 
point next to any of the sizes indicates 
that the photo will print at low quality 
at that size.

3. You will need an Apple account with 
1-click purchasing enabled to place an 
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order. To enable 1-click purchasing, 
click on Set Up Account and enter 
your Apple ID and password, then 
click on Sign In to access your Apple 
account.

4. In the Account Info window, make 
sure the box next to Enable 1-Click 
Purchasing is checked, then click on 
Edit Shipping or Edit Billing if you 
need to make changes to your 
account information. Click on Done 
when you’re finished to return to the 
Order Prints window.

5. Choose the person you want to send 
the photos to using the Ship To 
pulldown menu and choose a shipping 
method using the Ship Via pulldown 
menu.

6. Click Buy Now to place your order.

Books
With iPhoto, you can create your own 
beautifully designed photo books to print 
yourself, or you can have them 
professionally printed and bound. 
 
To create a new book in 
iPhoto: 
1. Select an album or a group of photos 

you want to include in the book. 
2. Click on the Book button in the 

toolbar.
3. Select a book type (hardcover, 

softcover, or wire-bound) and size 
from the pulldown menu at the top of 
the window.

4. Choose a theme (or layout) from the 
column on the left. A preview will be 
displayed on the right. 

5. Click on the Options + Prices button 
to see pricing options if you decide to 
have your book professionally printed. 
Pricing information will be displayed in 
your default web browser once you 
click on this button. 

6. Click on Choose once you’ve selected 
a theme to switch to book view. You 
will see a browser at the top of the 
window.  

7. Click on the top button on the left side 
of the browser to display thumbnails 
of the pages in your book. 

8. Choose a page you want to add 
photos to, then switch the browser to 
photo view using the bottom button on 
the left side of the browser. 

9. Start dragging photos from the 
browser to the placeholders in the 
book page. As you add photos to the 
book, the thumbnails in the browser 
will be marked with a checkmark. 
Repeat steps 7-9 with the other pages 
in your book. If you add a photo that is 
too small and would result in a low 
quality print, an exclamation mark will 
be displayed in the upper right corner 
of the photo in the layout.

10.A quick way to create a book is by 
clicking on the Autoflow button in the 
toolbar. iPhoto will then automatically 
fill the placeholders in your book with 
the photos in the browser.   

11.Some of the pages will include 
placeholder text for titles or captions. 
To edit this text, double-click on it to 
select it and replace it with your own 
text. 

12.Click on the Settings button to change 
the fonts used in your book design. 

13.To change the layout or background 
color of any individual page, make 
sure it is selected in the browser and 
then click on either the Layout or 
Background button..

14.To add pages to a book, click on the 
Add Page button until you have the 
desired number of pages.

15.To change the book type or theme at 
any time, click on the Themes button. 

16.Once you have set up your book, click 
on the Buy Book button to connect to 
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the Apple website and purchase your 
book. 

Books can also be exported as 
QuickTime movies that can be posted on 
the Web or included on a CD. To export a 
book as a QuickTime movie, select File > 
Export, choose a size for the movie and a 
save location and click on Export.

Calendars and Greeting Cards
The steps for creating a calendar will be 
similar to the steps for creating a book:
1. Select the photos you want to include 

in the calendar and click on the 
Calendar button.

2. Select a theme and click on the 
Choose button.

3. Set the options for your calendar, 
such as the month when you want 
your calendar to begin, the number of 
months to include, and the country if 
you want to display national holidays. 
You can also choose to import an iCal 
calendar or to display the birthdays of 
your contacts in Address Book. 

Once you set your options and click on 
OK, you will see a display similar to the 
one you see when you are creating books 
(except that the browser will be on the 
left). Assemble your calendar by dragging 
photos from the browser into the 
placeholders in the calendar pages. 
When you’re finished designing your 
calendar, click on the Buy Calendar 
button. 

To create a greeting card:
1. Select a picture from your library and 

click on the Card button. 
2. Select a theme and click on Choose.
3. Change the background color by 

clicking on the Background button at 
the bottom of the window. To change 
the design, click on the Design button.

4. Use the orientation pulldown menu to 
change how your card will open 
(either vertically or horizontally).

5. Edit the placeholder text by double-
clicking to select it and entering your 
own text. You can click on the settings 
button to change the fonts used in 
your card.

6. Click on the Adjust button if you need 
to edit the photo used in your card.

7. When you’re ready to order your 
greeting card, click on the Buy Card 
button.

Backing Up
It is important to back up your photos on 
a regular basis to prevent loss should 
anything happen to your computer.

To back up your photos to a CD or DVD:
1. Select the photos you want to burn to 

a disc.
2. Select Share > Burn.
3. Insert a blank CD or DVD into your 

drive.
4. Name your disc and click on the Burn 

button.

Keyboard Shortcuts 
• Command + N (new album)
• Command + D (duplicate a photo)
• Command + R (rotate a photo)
• Command + Option + R (rotate a photo 

in opposite direction)
• Command + 0-5 (Assign a rating)
• E - switch to Events view
• Spacebar - while scrubbing through an 

Event (Sets a new Key photo)
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