
Site Management
The Site Organizer allows you to man-
age the web pages that make up an 
iWeb site.  

To create a new website in iWeb:
1. Launch iWeb by clicking on its icon 

in the Dock or in the Applications 
folder.

2. In the .Mac information screen, 
click on Sign In if you already have 
a .Mac account, or on Close if you 
don't have an iWeb account. 

3. Check the box next to "Don't show 
this message again" if you want to 
keep this window from being dis-
played each time iWeb opens.

4. When the Template Chooser 
opens, select a template from the 
list on the left, then choose a page 
type for the first page in the site by 
clicking on one of the thumbnails on 
the right.  If the Template Chooser 
does not come up automatically 
when you open iWeb, choose File > 
New Site.

5. Click on Choose to create a new 
site with the selected template.

6. Choose File > Save to save your 
site.

7. The new site will be listed in the 
Site Organizer (the column on the 
left) with the default site name.  
To rename the site, double-click on 

its name to select it and type in the 
name you want to use.

To add a page to the new site:
1. Click the Add (+) button at the bot-

tom of the Site Organizer to open 
the Template Chooser and select a 
page type for the new page.  

2. Click on Choose to add the page to 
the site.

3. Repeat steps 1 and 2 to add pages 
as needed.

4. To rename a page, double-click on 
its name in the Site Organizer and 
type in the name you want to use 
for it.

5. To delete a page, click on its icon in 
the Site Organizer, then choose 
Edit > Delete Page. You must have 
at least one page in an iWeb site.  If 
you delete the last remaining page 
of an iWeb site, the Template 
Chooser will open so you can cre-
ate a new page.

6. The first page listed in a site is the 
start page for that site.  To change 
the order of pages, drag and drop 
the pages in that site until they are 
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in the desired order in the Site Or-
ganizer.

You can create multiple sites in iWeb.  
To create additional sites, choose File 
> New Site and repeat the steps in this 
section.  To delete a site, select it in the 
Site Organizer and choose Edit > De-
lete Site.

Navigation
iWeb automatically creates a naviga-
tion bar which appears at the top of 
each page in a site.  The navigation 
bar automatically updates as you add 
and remove pages.  

To hide the navigation bar and create 
your own navigation links:
1. Open the Inspector and select the 

Site Inspector.
2. Uncheck the box next to “Display 

navigation menu.”
3. If you only want to remove a single 

page from the navigation bar, select 
the page in the Site Organizer and 
uncheck the box next to “Include 
page in navigation menu.”

Working with Text
iWeb templates include placeholder 
text to show you exactly how your text 
will be formatted.  To replace the 
placeholder text, double-click to select 
it and begin typing your own text.  

There are several ways to format text 
in iWeb:
• To change the spacing and align-

ment, open the Inspector and select 
the Text Inspector.  Use the sliders to 
change the character, line, and para-
graph spacing.  Click on the buttons 
at the top to change the alignment, or 
click on the color well to change the 
text color.  

• To change the font and style, click on 
the Fonts button in the toolbar and 
select a font family, font typeface, 
and size using the different columns.  
The buttons at the top of this window 
will allow you to add underlining, a 
shadow, or other styling to your text.

• To add a list, place the cursor in the 
line where you want to start your list, 
open the Text Inspector and select a 
list type using the drop-down menu in 
the List pane.  A new list item is cre-
ated each time you press Return.  To 
create a line break without creating a 
new list item hold down the Shift key 
on your keyboard as you press Re-
turn.   

To add your own text boxes, click on 
the Text button in the toolbar then 
modify the text box as follows:
• To move a text box, click on it to se-

lect it and move it to another location.  
• To resize the text box, drag on one of 

the handles that appear when you 
click on it.

Links
To add a hyperlink: 
1. Select the text or object you want to 

turn into a hyperlink. 
2. Open the Hyperlink inspector.
3. Check the box next to "Enable as a 

hyperlink."
4. Using the drop-down menu, select 

one of the link types:
• One of My Pages: use this option 

to link to another page in your 
site.  Use the Page drop-down 
menu to select the name of the 
page.

• An External Page: select this op-
tion to link to a page on the Web.  
Enter the web address of the 
page in the URL field. 
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• E-Mail Message: use this option 
to create a contact link.  Enter a 
recipient address and a subject in 
the corresponding fields.  

Images
iWeb templates also include place-
holder images.  There are several 
ways to add images to an iWeb site:
• Drag and drop an image from a 

Finder window until it is over the 
placeholder image.  . 

• Select a placeholder image and then 
choose Insert > Choose to navigate 
to the location where the image is 
stored on your hard drive.  Select the 
image and click on Choose to re-
place the placeholder image.  

•Click on the Media button in the tool-
bar, then click on the Photos pane 
and choose an image from your 
iPhoto library or from one of your 
iPhoto albums.  Drag the image into 
the canvas until it is over a place-
holder image.

Once you have added an image to a 
page, you can drag it to a different lo-
cation or use the handles that appear 
around it to resize it.

The Graphics Inspector can be used to 
further customize the appearance of an 
image:
• Check the box next to Shadow to add 

a drop shadow.  Use the controls to 
change the angle, offset, and other 
options for the drop shadow.

• Check the box next to Reflection to 
create a reflection effect.  Use the 
slider to change the opacity of the 
reflection.

• Use the opacity slider to increase the 
level of transparency in the image.

The Metrics Inspector also has options 
that apply to images:
• Use the flip buttons to flip the image 

vertically or horizontally.
• Use the Angle wheel to rotate the im-

age.
  

The Adjust Image window allows you 
to adjust the colors and lighting in your 
images without having to open iPhoto:
1. Select the image you want to edit 

and click on the Adjust button in the 
toolbar to open the Adjust Image 
window.

2. Use the sliders to change the over-
all brightness and contrast, or fix 
the colors in your image.

3. The histogram at the bottom of the 
window displays tonal information 
for your image.  Use the Exposure 
slider to change the mid-tones in 
your image.  To work with the 
shadows or highlights individually, 
use the markers below the histo-
gram.  Drag in from the left to in-
crease the shadows (and make the 
image darker), or from the right to 
bring out the highlights (and make 
the image brighter).

4. To perform an automatic adjust-
ment, click on the Auto Levels but-
ton.  If you’re not happy with the 
results, click on Reset Image to 
start over. 
 

When you add an image to a page it 
can be added inline or fixed on the 
page.  Inline images move along with 
the text as you type, and they can 
have text wrap around them.  Fixed 
objects can be dragged to any location 
on the page and they do not affect the 
flow of the text.  To wrap text around 
an image:
1. Select an inline image in the can-

vas.
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2. Open the Wrap pane of the Text 
Inspector.

3. Check the box next to “Object 
causes wrap”.

4. Click on one of the buttons to have 
the text wrap around the right or left 
side of the image.

5. To add white space between the 
image and the text, enter a value in 
the Extra Space field.

iWeb allows you to mask or hide parts 
of an image.  To mask an image:
1. Select the image in the canvas and 

click on the Mask button in the tool-
bar.

2. The grayed out area is the part that 
will be hidden.  To change the size 
of the masked area move the 
bounding box and drag on the han-
dles.

3. Press Return on your keyboard to 
set the mask.  If you want to re-
move the mask, select the image 
and click on the Unmask button in 
the toolbar.

Images can be layered in iWeb by 
placing them on top of each other.  The 
layer order can be controlled using the 
Forward and Backward buttons in the 
toolbar.

Shapes
Shapes can be used in iWeb to create 
rounded text boxes and callouts.  To 
add a shape, click on the Shapes but-
ton in the toolbar and select the shape 
type you wan to add.  To add text to a 
shape, double-click inside of it and be-
gin typing.
  
Shapes behave like images in iWeb.  
As with images, you can edit a shape 
by selecting options in the Graphics 

and Metrics Inspectors.  You can 
change the fill and stroke colors, or 
add a drop shadow.  

Photo Pages
One of the page types included in 
iWeb allows you to quickly build a 
photo gallery.

To create a Photos page in iWeb:
1. Click on the Add (+) button to add a 

new page to the site.
2. When the Template Chooser 

opens, select the Photos page type.
3. Click on Choose to add the page to 

the current site. The new page in-
cludes a grid with placeholder pho-
tos.

4. Click on the Media button in the 
toolbar to open the Media Browser, 
then select the Photos pane.

5. Drag an image from the Media 
Browser until it is over one of the 
placeholder photos.  The first photo 
added replaces all the placeholder 
photos in the grid.  

6. Continue dragging photos from the 
Media Browser to add them to the 
grid.  The existing photos move to 
create space for the photos you are 
adding.  

7. To add multiple photos, drag an al-
bum from iPhoto into the grid.  The 
first 99 photos in the album are 
added to the photos page.

8. To rearrange the order of photos in 
the grid, drag and drop until the 
photos are in the desired order.

9. To edit the caption text below an 
image (by default the file name is 
used), double-click on it to select it 
and begin typing.
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To create a Photos page from iPhoto, 
select an album and choose Share > 
Send to iWeb > Photo Page.
 
Blogs
A blog is an online journal.  To create a 
new blog in iWeb:
1. Click on the Add (+) button to add a 

new page to the site.
2. Select the Blog page type in the 

Template Chooser.
3. Click on Choose to add the page to 

the current site.  Three icons are 
created in the Site Organizer:
• Blog: This is the page your web-

site visitors see.  It contains ex-
cerpts of the five most recent en-
tries in the blog.  You can edit the 
title and description for the blog 
by replacing the placeholder text 
in this page.

• Entries: This is where you create 
and manage your blog entries.  
Your website visitors don’t see 
this page.

• Archive: This page includes all 
blog entries, including those that 
don’t appear on the main page.  
The blog templates include a link 
to the archive on the main page.
  

4. To add a new entry, select the En-
tries icon in the Site Organizer and 
click on the Add Entry button in the 
Title List.  iWeb will automatically 
add the date to each new entry.

5. To change the title of a new entry:  
• double-click the placeholder title 

text on the page and type in the 
title you want to use, or

• double-click the title in the Title 
List and type the title you want for 
your new blog entry.

6. To edit the text in a blog entry, click 
on its title in the Title List to display 
its page.  You can then edit it as 
you would any page in iWeb.  

7. To delete a blog entry, click on the 
Delete Entry button in the Title List.

To change the options for a blog:
1. Select the Blog icon in the Site Or-

ganizer.
2. Click on the Inspector button in the 

toolbar and select the RSS Inspec-
tor.

3. Enter the number of entries in the 
excerpts field.  Use the slider to de-
termine the length of each entry.

4. Check the box next to “Allow com-
ments” if you want your website 
visitors to be able to comment on 
your blog entries.  Your site must be 
hosted on a .Mac account for com-
ments to work.  

When you create a blog, iWeb auto-
matically adds a Subscribe link with the 
RSS icon on the main page of the 
blog.  

Your website visitors can click on this 
link to subscribe to your blog using an 
RSS reader or a website that supports 
RSS subscriptions (such as Bloglines 
or Google Reader).

Podcasts
iWeb includes two kinds of blog tem-
plates: Blog and Podcast.  You can 
create podcasts using either template, 
but if your blog will contain mainly pod-
casts you should use the Podcast tem-
plate.  

There are two ways to create a pod-
cast using iWeb: 
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• start off in iWeb and use the Media 
Browser to find media files on your 
computer, or 

• start off in Garageband or iMovie and 
send a podcast to iWeb.  

To create a podcast in iWeb:
1. Click on the Add (+) button to cre-

ate a new page.
2. Select the Podcast page type in the 

Template Chooser and click on 
Choose.

3. Select the Entries icon in the Site 
Organizer.  

4. Click on the Add Entry button in the 
Title List.

5. Edit the new entry as you would 
when adding a new blog entry.

6. Drag a media file from the Media 
Browser or from a Finder window 
until it is over one of the placehold-
ers.  

7. Repeat step 6 to add more entries 
to the podcast.  Each entry will be a 
new podcast episode.      

To create a podcast from Garageband:
1. Create the podcast in Garageband.  
2. Choose Share > Send Podcast to 

iWeb.
3. The Template Chooser opens with 

the Podcast page type already se-
lected.  Click on Choose to create 
the podcast.  

If you have more than one blog, a dia-
log box appears before the Template 
Chooser opens to let you choose the 
blog you want to use.    

To create a video podcast from iMovie:
1. Create a movie in iMovie and 

choose Share > iWeb.
2. Choose “Share for video podcast” 

and click on Share.

3. Select a page type (Blog or Pod-
cast) using the Template Chooser.  
If you have more than one blog, a 
dialog box appears before the 
Template Chooser opens to let you 
choose the blog you want to use. 

Each time you create a podcast, iWeb 
automatically adds a Subscribe to pod-
cast link to the main page of the blog.  

Your website visitors can use this link 
to subscribe to your podcast using 
iTunes or any program that supports 
podcasts.

You can use iWeb to submit a podcast 
to the iTunes Store.  To submit a pod-
cast:
1. Select the main page of the pod-

cast (click on Blog or Podcast in the 
Site Organizer, depending on which 
template you selected when you 
added the blog to the site.)

2. Open the Inspector and select the 
RSS Inspector.  Click on the Pod-
cast pane.

3. Enter the descriptive information for 
your podcast series and podcast 
episode.

4. Check the boxes next to “Allow 
Podcast in iTunes Music Store.”

5. Choose  File > Submit Podcast to 
iTunes.

6. Enter the additional information in 
the dialog box, such as the cate-
gory, language, and parental advi-
sory rating.  

7. Click on Publish and Submit.
8. Follow the instructions in the iTunes 

window to complete the submission 
process. 
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Movie Pages
iWeb has a special template for movies 
that are not included in a podcast.  To 
add a Movie page to an iWeb site:
1. Click on the Add (+) button, select 

the Movie page type in the Tem-
plate Chooser, and click on 
Choose.  

2. Drag a movie file from a Finder 
window or the Media Browser until 
it is over the placeholder in the 
movie page.

3. To add a description, double-click 
on the placeholder text below the 
movie and type your own text. 

To create a Movie page from iMovie:
1. Create a movie in iMovie and 

choose Share > iWeb.
2. Choose “Share for web” and click 

on Share.
3. Click on Choose when the Tem-

plate Chooser opens up with the 
Movie page type already high-
lighted.

Special Elements
iWeb allows you to add several special 
elements to a website.

To add a Date and Time Field:
1. Insert a Text box by clicking on 

the Text button in the toolbar.
2. Click inside the Text box and 

choose Insert > Date & Time.
3. Select a format in the Date and 

Time dialog box.
4. Check “Automatically update the 

date and time” if you want the 
date and time to be updated 
each time you open iWeb.

5. Click on Insert.

To add an Email Me button:
1. Place the cursor where you want to 

insert the Email Me button.
2. Choose Insert > Button > Email Me.

If you publish your site using a .Mac 
account, your .Mac email address is 
used.  If you use a different account, 
the address in your card in Address 
Book is used instead.

A hit counter is included with most 
iWeb templates to let you know how 
many people visit your site.  

To add a hit counter (only works if the 
site is published using .Mac):
1. Go to page where you want to in-

sert the hit counter.
2. Choose Insert > Button > Hit 

Counter.
3. Drag the button to the location on 

the page where you want it to ap-
pear once the site is published.  
You can’t resize the counter or 
modify it. 

Publishing
Once you’re finished creating your 
iWeb sites, you need to publish them 
to a web host so that other people can 
access them online.  

To publish a site using a .Mac account:
1. Choose File > Publish to .Mac.  The 

icons for the site and its pages will 
change from red to blue in the Site 
Organizer once they’re published.

2. To view the published site using a 
web browser, click on the Visit but-
ton below the Site Organizer or 
choose File > Visit Published Site. 
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3. If you need to email the address to 
other people, the format is:
http://web.mac.com/yourusername.  

If you have more than one site, the 
format will be:
http://web.mac.com/yourusername/i
Web/sitename.

Some of the features available in iWeb 
will only work when a site is published 
using a .Mac account.  One of these 
features is password protection.  

To use a password on a .Mac site:
1. Select the site in the Site Organizer.
2. Open the Inspector and select the 

Site Inspector.
3. Click on the Password pane and 

check the box next to “Make my 
published site private.”  

4. Enter the user name and password 
visitors to your site will need to en-
ter before they can view the site. 

To publish your site to a web host other 
than .Mac:
1. Choose File > Publish to a Folder.
2. Choose a location to save your 

site’s files.
3. Enter the URL for the site.  This ad-

dress is used to create the RSS 
feeds for blogs and podcasts in the 
site.

4. Click on Choose to save your site 
to a folder on your computer.

Once you’ve saved the site to a folder, 
you can use an FTP program to upload 
the files to your web host.

Backing Up
You can back up iWeb sites (and trans-
fer them between computers).  

To back up your iWeb sites:
1. Click on the icon for your hard drive 

(Macintosh HD).
2. Go to Users > Your User Name > 

Library > Application Support > 
iWeb and copy the Domain file.

To restore iWeb sites from a backup, 
copy the Domain file from the backup 
location to Users > Your User Name > 
Library > Application > Support > iWeb. 

Created by Luis Perez
Last Updated: 3/31/08


