
 

GarageBand ‘08 is the audio application included with iLife ‘08. With GarageBand, you can record vocals 
using a microphone, or your own music using a keyboard or any instrument that can be connected to the 
computer. GarageBand also includes an eclectic collection of music loops for use in your projects, and 
you can import a number of file types as well. With the Magic GarageBand feature, you don’t have to start 
every project from scratch. You can use a virtual band to preview songs from a variety of genres and use 
them as the foundation for your project. GarageBand ’08 also introduces multi-take recording so you don’t 
have to get your song right the first time.

Hardware Setup
You can connect a microphone directly into your 
computer’s audio line in port or you can use a 
USB microphone. Once you connect the 
microphone to the audio line in or USB port, you 
may have to change your audio preferences to 
make the microphone available to GarageBand:
1. Select Apple > Preferences to open up the 

System Preferences window.
2. Click on Audio and select the Input tab.
3. Select the microphone from the list at the top 

of the window. 

To enable the microphone in GarageBand:
1. Select GarageBand > Preferences. 
2. Click on the Audio/Midi button at the top of the 

window.
3. Select the microphone uisng the Audio Input 

pulldown menu.
 
Most musical instruments will first connect to an 
audio interface that will then connect to your 
computer using either a USB or Firewire cable. 
The steps for setting up a musical instrument 
using a USB or Firewire audio interface are the 
same as for setting up a microphone.

Magic GarageBand
GarageBand ’08 gives you a head start on any 
project by allowing you to use a virtual band to 
create a composition with all the instruments you 
need.

To create a project using Magic GarageBand:
1. Click on the Magic GarageBand 

button in the GarageBand splash 
screen. 

2. Choose a genre by clicking on one of the 
thumbnails.

3. Choose whether you want to hear a snippet 
or the entire song using the rocker button next 
to the play button.

4. Click on the Play button to start the preview. 
Use the slider to the right of the play button to 
adjust the volume of the preview. 

5. Once you find a genre you like, click on the 
Audition button to open the virtual band 
window. Click on the Change Genre button to 
go back and select a different genre.

6. To change an instrument in your virtual band, 
click on the instrument to spotlight it and 
choose a different instrument from the list that 
appears below the virtual band. You can take 
out an instrument by choosing None from the 
list.

7. Click on Create Project to open the project for 
editing in GarageBand.

Creating a New Project
To create a new music project from scratch:
1. Select File > New or click on the 

New Music Project button on the 
GarageBand splash screen.

2. Enter a name for your project file.
3. Choose a save location using the pulldown 

menu. If you do not see the location you 
need, click on the down arrow next to the 
Save As field to display more locations.

4. Set the tempo, time signature and key. 
5. Click on Create.
6. GarageBand will display an on-screen 

keyboard you can use to record your audio if 
you do not have a physical keyboard. 
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If you do not need the on-screen keyboard, 
close it by clicking on the red button in the 
upper left corner of the keyboard window. 

7. As you work on your project, make sure to 
save frequently by selecting File > Save.

Track Controls
The track controls determine how a track 
behaves. 

From left to right, these controls are:
• Enable recording: this button must be turned on 

before you can record to the track.
• Mute: turns off playback on the track.
• Solo: allows you to mute all other tracks and 

play back the track by itself.
• Lock: disables editing on the track so you don’t 

make unwanted changes once you have all 
your settings the way you need them.

• View/Hide Automation: displays volume, pan 
and automation (effects) curves which can be 
used to adjust these settings over time.

Working with Tracks
A GarageBand project is created by adding a 
track for each instrument you want to use in your 
recording. GarageBand supports two types of 
instruments: 
• Real Instruments: voice and other sound that 

can be recorded with a microphone or any 
instrument you can connect to your computer 
with an audio interface, with the exception of a 
MIDI keyboard. Includes GarageBand loops as 
well.

• Software Instruments: sound created by 
GarageBand and playable on any USB or MIDI 
keyboard.

The Track menu allows you to perform the 
following track-related actions:

Add a Track: 
1. Select Track > New Track.
2. Select Real Instrument (if you’re using a 

microphone or audio interface) or Software 
Instrument (if you want to use computer 
generated instruments created within 
GarageBand) and click on Create.

3. GarageBand will add a track with the default 
instrument and the Track Info pane will 
display to the right. To change the instrument, 
choose an instrument category on the left 

side of the pane, then select an instrument on 
the right side.

4. Click on the arrow next to Details if you want 
to set instrument options. You can add effects 
and more in this area.

5. If you want to use the same instrument 
settings in the future, click on Save 
Instrument.

Duplicate a Track:
To create a new track with the same settings as 
an existing track, select Track > Duplicate Track 
or hold down the Command key and press the 
letter D.

Create a Basic Track:
Select Track > New Basic Track to create a track 
that does not have an instrument assigned to it. 
You can assign an instrument of your choice by 
clicking on the Track Info button and 
selecting it from one of the categories.

Delete a Track:
Select the track (the icon for the instrument will 
have a glow around it) and choose Track > Delete 
Track or hold down the Command key while you 
press Delete on your keyboard.

Recording
Once you have created a new track, you’re ready 
to record:
1. Make sure the track is enabled for recording 

by clicking on the Enable Recording button in 
the track controls. 

2. Click the Record button in the controls 
area that appears below the timeline or 
press the letter R on your keyboard.

3. When you’re done recording, click the Record 
button again, or press the letter R on your 
keyboard. 

4. To preview your recording, move the 
playhead to the beginning by using the button 
in the controls area or press the letter Z on 
your keyboard.

5. Press the Space Bar on your keyboard to 
begin playing your recording. Press the 
Space Bar to stop the playhead.

Working with Regions
Each time you press the Record button, 
GarageBand creates a new region in the track 
you have selected. The color of the region will 
indicate what type of region it is:
• Purple: real instrument you record
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• Blue: real instrument created from a loop
• Orange: imported audio file
• Green: software instrument 

You can edit these regions in a number of ways: 
• Move: Click on it and drag it to another location 

in the timeline (either on the same track or on 
different track.). 

• Trim: Place your pointer over the lower half of 
one of the edges until it turns into a bar with an 
arrow on it. Drag in to trim the region. On 
software instrument regions, drag out to add 
silence at the beginning or end of the region.

• Loop: Place your pointer over the upper part of 
the right edge until it turns into a bar with a 
curved arrow on it, then drag to the right.

• Duplicate: Hold down the Option key as you 
drag the region and it will be duplicated.

• Delete: Select the region and press the Delete 
key on your keyboard.

• Split: Place the playhead where you want to 
split the region and select Edit > Split.

GarageBand ’08 supports cycle regions to allow 
you to do multiple takes of a recording. To Create 
a cycle region:
1. Click on the Cycle button in the controls area.
2. The cycle region will appear as a yellow area 

in the timeline. Move the region to where you 
want to start recording. To resize the cycle 
region, drag in on the edges of the cycle 
region.

3. Place your cursor at the beginning of the 
cylce region and record your first take. Press 
the Play button when you’re finished 
recording. Repeat to record additional takes. 

4. To preview each take, click on the circle with 
the number in the upper left corner of the 
region.

5. To keep just one take, click on the circle with 
the number of takes, choose the take you 
want to keep (it should have a check mark 
next to its name), and then choose Delete 
Unused Takes from the same menu. 

Another new feature in GarageBand ’08 is the 
ability to arrange regions into sections such as 
intro, verse, and chorus using the arrange track in 
the GarageBand timeline:
1. Choose Track > View Arrange Track.
2. Click on the plus button to create a new 

arrange region. To rename the arrange 
region, click on its name, wait a few seconds, 
then type the name you want to assign to it.

3. To resize the arrange region, drag in from the 
edges. To move it, drag it to another location 
in the timeline. To copy it, hold down the 
option key as you drag to another point in the 
timeline. When you move or copy an arrange 
region, the music in all of the tracks in that 
region are moved or copied.

The Track Editor
The Track Editor allows you to edit the contents of 
a region. The display on the Track Editor will 
depend on what type of region you have selected. 
For real instrument regions, the Track Editor will 
display a waveform of the recording.

To remove a section of the waveform in the Track 
Editor:
1. Select the region you want to edit.
2. Click on the Track Editor button.
3. When the Track Editor opens, position 

your pointer somewhere in the lower 
part of the waveform (until it turns into 
crosshairs) and make a selection.

4. Select Edit > Cut or hold down the Command 
key and press X on your keyboard.

Notation View
When you open up the Track Editor with a 
software instrument region selected, you can edit 
the individual notes in that region in notation view:
1. Select the region you want to edit and click on 

the Track Editor button.
2. Switch to notation view by clicking 

on the button with the musical note 
on it.

3. To move a note, select it and drag it to 
another spot in the notation area. You can 
drag the note up and down to change its 
pitch. 

4. To add a note, first click on the Note Value 
button and choose the Note value, then hold 
down the Command key and click in the 
notation area where you want to add the note. 
To copy a note, hold down the Option key as 
you drag the original note to another spot in 
the notation area.

5. To delete a note, click on it to select it and 
press Delete on your keyboard.

6. To print the notation area, choose File > Print.

Adding Loops
GarageBand includes loops of prerecorded music 
that can be used to add drum beats and other 
repeating elements.
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To add a loop to a project:
1. Click on the Loop Browser button.
2. Select a category by clicking on one of 

the buttons.
3. The loops in that category will be listed to the 

right. Double-click on a loop to preview it.
4. When you find one you like, drag it into the 

main window. GarageBand will create a new 
track with a loop region in it. To extend the 
loop, place your pointer over the upper part of 
the right edge until it turns into a bar with a 
curved arrow on it, then drag to the right.

Importing Music
GarageBand supports the MP3, MIDI, WAV, and 
ACC file formats. There are two ways to import an 
audio file: using the Media Browser or from a 
Finder window.

To import a file using the Media Browser:
1. Click on the Media Browser button.
2. Select the Audio tab at the top of the 

Media Browser.
3. Click on iTunes and select a file from the list. 

Click on the Play button to hear a preview.
4. Drag the file into the gray area in the 

GarageBand window. GarageBand will create 
a new track when you release the mouse.

To import a file using the Finder:
1. Resize the GarageBand window so you can 

see the file you want to import.
2. Drag the file from the Finder window until the 

pointer has a plus sign on it.
3. Release the mouse to create a new track with 

the audio from your file.

Adjusting Volume and Pan
To adjust the volume level and pan on any track:
1. Display the Track Mixer by selecting Track > 

Show Track Mixer. The volume indicators will 
indicate your volume level as two bouncing 
green bars (only one bar if you’re recording in 
mono). These two bars will hit a red point if 
your volume is too high.

2. Use the slider below the indicators in the 
Track Mixer to adjust the volume level. The 
pan wheel in the Track Mixer allows to place 
instruments in the stereo field. Drag the wheel 
to either side to have instruments play out of 
either the left or right channel. 

3. To adjust the volume or pan dynamically over 
time, display the volume or pan curve by 
clicking on the down arrow in the track 
controls, then choosing Track Volume or 
Track Pan using the pulldown menu. 

4. Click on the curve to add points you can use 
to change the shape of the curve. These 
points can be used to create fades and other 
effects.

When you’re finished editing a track, you can lock 
it to prevent it from being accidentally changed. To 
lock a track, select the lock icon in the track 
controls area.

Each GarageBand project includes a Master 
Track which determines the volume level for the 
entire project. To adjust the volume of the Master 
Track, first choose Track > Show Master Track, 
then make sure Master Volume is selected in the 
pulldown menu on the left side of the track. You 
can then drag the volume curve up to raise the 
overall volume or set points in the volume curve 
to change the volume over time. 

Effects
GarageBand includes studio-quality effects you 
can use to enhance your audio. The effects are 
available in the Details area of the Track Info 
pane.
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To add an effect to a track:
1. Select the track, then click the Track Info 

button.
2. Click on Details to show the track’s effects 

settings.
3. Click the checkbox next to an effect to turn 

the effect on or off.
4. To adjust the gate, echo, and reverb effects 

use the sliders to make adjustments until you 
get the sound you want.

5. Other effects can be added by changing the 
value of one of the pulldown menus on the left 
side of the pane from None to the effect you 
want to use, then choosing an option from the 
Preset pulldown menu. To edit the parameters 
of an effect, click on the Edit button 
with the pencil icon.

The Visual EQ effect allows you to modify the 
different frequencies in a recording. To use the 
Visual EQ:
1. Click the box next to Visual EQ in the Details 

area of the Track Info pane.
2. Choose one of the presets using the Preset 

pulldown menu. 
3. To bring up the Visual EQ window, click on 

the edit button with the pencil icon to the right 
of the pulldown menu. This will bring up the 
Visual EQ window.

4. Check the box next to Analyzer to see a a 
frequency curve (showing which frequencies 
are louder or softer) as you play your project. 
Make sure to turn off the Analyzer when you 
don’t need it, as it takes up a lot of CPU 
resources when it is on.

5. To adjust a band (bass, low mid, high mid, 
and treble) click on the area for that band and 
drag up or down to make your adjustment. 
You can drag to the left and right to change 
the pitch.

With GarageBand ’08 some effects can be 
applied dynamically over time using an 
automation curve similar to the volume and pan 
curves. To use automation:
1. Click on the down arrow in the track controls.
2. Choose Automation from the pulldown menu 

below the track controls.
3. Click on the triangle next to Visual EQ or 

Echo and Reverb to see the effects in each 
category, then check the box next to the 
effects you want to add.

4. To modify an effect, choose it using the 
pulldown menu below the track controls, then 

click on the automation curve that is displayed 
below the track’s regions to set points you 
can use to change the shape of the curve. 

Exporting
To share your audio, you have to export it into a 
format that can be played outside GarageBand.

To export a recording:
1. Select Share > Export Song to Disk.
2. Enter a name for your exported song and 

choose a save location.
3. Click on Save. 

GarageBand will save your song as an AAC file 
you can play on iTunes and other programs that 
support that format.

If you select Share > Send Song to iTunes, your 
song will be exported as an AIFF file and iTunes 
will open and automatically play it. If you plan to 
share your song with others, you should export it 
to either AAC or MP3, as these formats are more 
commonly supported. 

To convert your song to AAC or MP3:
1. Choose the format used to convert the song 

file. Select iTunes > Preferences > Advanced.
2. In the Importing tab, choose MP3 Encoder or 

AAC Encoder from the Import Using pulldown 
menu. 

3. Click OK to close the iTunes preferences 
window.

4. Right-click or Control-click on your song file 
and select Convert Selection to AAC (or 
MP3). 

Keyboard Shortcuts
• R - Start/Stop recording
• Z - Move playhead to beginning of the timeline
• Space Bar - Play/pause playback
• Command + Option + N - Create a new track
• Command + Shift + N - Create a new basic 

track.
• Command + Delete - Delete a track
• Command + K - Show on-screen keyboard
• Command + T - Split a region
• Command + P (in Notation view) - Print notation
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