
 

iMovie ‘08 is a completely redesigned version of the video editing application included in iLife. iMovie ’08 
has a single library that allows you to gather video from many different sources and devices in one place. 
You can also group together all the clips from a single event, such as a wedding, vacation or birthday 
party. With the new “skimming” feature, you can quickly review your video to find the best moments to use 
in your movie. As with previous versions of iMovie, you can make your movie more interesting by adding 
background music, voice narration, titles, and transitions. There’s no need to save your project as you 
work on it. iMovie ’08 automatically saves your work. The finished movie can be shared with other people 
on the web, or it can be exported into a format that can be played on an iPod or a TV through Apple TV. 
This guide covers the features of version 7.1. 
    

The iMovie Interface
1. The Project Library lists all the projects you 

have created. 
2. The Project area shows how your clips are 

arranged in your project. 
3. The Viewer allows you to preview your video. 

This is also where you crop video or still 
images. 

4. The Toolbar has buttons for most common 
tasks available in the menus.

5. The Event Library lists every Event you’ve 
created to organize video clips into useful 
categories.

6. The Source area shows the clips in your 
Events, which you can then add to a project. 

7. The Browsers allow you to access music, still 
images, titles, and transitions by clicking on the 
appropriate button. To open a Browser, click on 
one of the buttons on the right side of the 
toolbar.

iMovie ’08 Basics 
 Created by Luis Perez
Page 1 of 7
 Last Updated: 5/23/08

iMovie ‘08 Basics
Website: http://etc.usf.edu/te/

1 2 3

5

4

6 7

http://etc.usf.edu/te/
http://etc.usf.edu/te/


Importing Video from a Camera
There are several ways to import video into 
iMovie ’08. iMovie ’08 supports the following 
devices:
• Firewire-equipped camcorders that use tapes.
• DVD, hard disk, or flash memory camcorders 

that connect to the computer using USB.
• digital still cameras that can record short video 

clips.
• iSight cameras built into a new Mac or 

connected through a Firewire cable.

To import video from a Firewire equipped 
camcorder into iMovie: 
1. Launch iMovie by clicking on its icon in 

the Dock (it looks like a star). iMovie 
should open  up to the last project you 
worked on. 

2. Select File > New Project... to create a new 
project. 

3. Enter a Project Name and select a size:
• Standard: produces a movie for viewing on 

a regular TV or on the web. When viewed 
on a high definition TV the video will have 
black space on the sides, known as “pillar 
box”.

• iPhone: produces a movie for viewing on an 
iPhone.

• Widescreen: produces a movie for viewing 
on a high definition TV. When viewed on a 
regular TV there will be black space above 
and below the video, known as “letterbox”.

4. Click on Create. The new project will be listed 
in the Project Library. 

By default, the Project Library is in the upper 
left area of the window, but you can switch its 
location to the bottom by clicking on the 
Swap events and projects button. 

5. Connect your camcorder to your computer 
using a Firewire cable and make sure it is 
turned on and in the correct mode for 
transferring video (this will depend on your 
model but is usually Play/VCR).

6. The Import window should open. If it 
does not, click on the Import button or 
select File > Import from Camera.

7. Make sure your camera is selected in the 
Camera pulldown menu.

8. Set the rocker button to Automatic 
if you want to capture the entire 
tape or Manual if you want to 
capture only part of the tape. When you 
choose Automatic, iMovie will rewind the tape, 
capture all the video on it, and rewind it again. 
When you choose Manual you can use VCR-
type controls to preview the video and choose 
where you want the import to begin.

9. Click on Import. A popup window will ask you 
to choose a save location and the Event 
where you want the video to be saved. Events 
allow you to group all clips from a single 
event, such as a wedding, birthday party, or 
graduation. 

10. To add the video to an existing event, click on 
the Add to existing Event button and choose 
one of the events listed in the pulldown menu. 
To add the video to a new event, click the 
Create new Event button and replace the 
default Event name with your own.  There is 
also a checkbox that allows you to split the 
video into separate events based on the day 
when it was shot. 

11. Click on OK once you’ve made your 
selections. 

12. iMovie will start importing your video. You will 
see the video play as it is imported. You can 
click on the Stop button at any time to stop 
the import. You may see a popup window 
informing you of the amount of video 
imported.

13. Click on Done to close the Import window 
when you’re finished. You can then turn off 
your camera and disconnect it from the 
computer.

Importing video from other types of video 
cameras, such as hard drive and Flash memory 
based cameras, will work in a similar way. 

To record video using an iSight camera, select the 
iSight camera using the Camera pulldown menu 
in the Import window and proceed as described 
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above (the only difference is that you will click on 
Capture instead of Import to begin recording).

To import video from a digital still camera:
1. Connect your still digital camera to the 

computer using a USB cable and turn it to the 
correct mode (this will vary by model but will 
usually be Play).

2. iPhoto will open to the Import window, which 
will show all the video clips on the digital 
camera.

3. Enter an Event name and a description 
(optional). 

4. Choose the video clips you want to import 
(you can choose several clips by holding 
down the Command key as you click on 
them) and click on Import Selected, or click 
on Import All to import all clips.

5. In iMovie, you can view the clips by clicking 
on iPhoto Videos in the Event Library.

 
Importing Video from a Hard Drive
You can also import movies already on your 
computer or even old iMovie HD projects:
• To import a video from your hard drive, choose 

File > Import Movies and find the movies you 
want to import on your hard drive. When you 
import a movie from a hard drive, you can 
delete the original after it is copied into iMovie 
’08 or leave it intact in its original location. 

• To import an iMovie HD project, choose File > 
Import iMovie HD Project.

Events
Events allow you to group video into useful 
named categories, even if the video is imported 
from different sources. Events are listed in the 
Event Library by the year and month in which they 
were created (choose these options in the View 
menu). To sort your Events by the hard 
drive where they’re stored, click on the 
Events by Volume button. 

There are a number of things you can do with 
Events:
• Rename an Event - double-click on its name 

and enter a new name.

• Merge two Events - hold down the Command 
key as you select the Event names in the Event 
Library, then choose File > Merge Events. 

• Split an Event - click on the video clip you want 
to make the first clip in the new Event and 
choose File > Split Event Before Selected Clip.

• Delete an Event - right-click or Control-click on 
the Event name and select Move Event to 
Trash. 

If you try to delete an Event that has clips being 
used in a project you will see an alert window. 
Choose Delete Unused to delete only the clips in 
that Event that are not being used in a project.

Previewing Source Video
When you select an Event in the Event Libary, the 
video clips in that Event are displayed in the 
Source area as filmstrips. Each thumbnail in the 
filmstrip is 5 seconds of video by default. A jagged 
edge indicates that the clip continues on a new 
line in the display. 
 
You can expand or contract the filmstrip to change 
the number of thumbnails by using the slider at 
the bottom of the Source area. This does not 
change the video in any way, it just changes the 
view. 

As you hover over a clip in the Source area with 
your cursor, a red “skimming” line will appear. 
Move the skimming line back and forth to preview 
your video in the Viewer. 

You can preview the video and sound at varying 
speeds by changing the speed at which you move 
the skimming line. To preview just the video, click 
on the Audio skimming on/off button. 

There are several ways to preview a source clip 
at normal speed in the Viewer:
• click on the Play button in the toolbar below the 

Event Library to view the video clip from the 
beginning.

• double-click anywhere on a clip to start 
playback from that point, or

• move the skimming bar until it is at the point 
where you want to start playback and press the 
Space Bar on your keyboard.
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To stop playback, click once anywhere in the 
iMovie window, press the Play button again, or 
press the Space Bar. 

To preview your video in full screen mode, 
click on the Full Screen button in the 
toolbar below the Event Library. A strip at the 
bottom of the full screen mode will allow you to 
skim the clip as well as pause and resume 
playback. To exit full screen mode and stop 
playback, press the Escape key or click on the X 
in the strip.

The same techniques can be used to preview 
video once it has been added to a project, but you 
will use the toolbar below the Project Library 
instead of the one below the Event Library.

Making Selections
You do not have to use an entire clip in your 
project. To select just a portion of a clip:
1. Click once on the clip to display a yellow 

selection area. By default, this area 
represents 4 seconds of video, but this can be 
changed in the iMovie preferences.

2. To expand or contract the selection, click on 
the edge of the selection area when the 
cursor changes to a bar with a double arrow 
and drag.

3. To recenter the selection area, place your 
cursor over the top part of the selection area 
(until it changes to a hand with a double 
arrow) and drag the selection area to another 
location in the clip.

If you do want to select the entire clip, hold down 
the Option key and click on the clip. To select 
multiple clips, hold down the Command key on 
your keyboard as you click on the clips you want 
to select. 

Marking and Sorting Clips
To mark a selection as a favorite, click on the 
Mark Selection as Favorite button (black star). 
This will place a green bar at the top of the 
selected video to let you know it is marked as a 
favorite. Click on the Unmark Selection button 
(white star) to undo this action. 
To mark video for deletion, click 
on the Reject Selection button 

(X). This will place a red bar at the top of the 
selected video to let you know it has been 
rejected.

Using the Show pulldown menu, you can filter 
your video as follows:

• All Clips: shows all video without any filters.
• Favorites and Unmarked: the default view which 

shows all video marked as favorite or left 
unmarked.

• Favorites: shows only video marked as favorite.
• Rejected Only: shows video marked for 

deletion.

To delete video once it has been marked as 
Rejected, choose Rejected Only from the Show 
menu and then click on the Move Rejected to 
Trash button.

Enhancing Video
iMovie ’08 allows you to enhance your video in 
two ways: you can crop it, or you can enhance the 
lighting and colors.

To crop your video:
1. Click on the Crop button in the toolbar 

and then click on a clip to select it.
2. Click on Crop in the viewer to display a green 

box.
3. Drag the handles on the green box to resize 

it, or drag the box and reposition it to change 
the area that will be cropped.

4. To preview the cropped video, click on the 
Play button in the Viewer (click the Space Bar 
to stop playback). 

5. To undo a crop, click on the Fit button.
6. When you’re finished making your selectiion, 

click on Done and the video will be cropped 
(this will affect the entire clip).

To enhance the color and lighting:
1. Click on the Adjust Video button and 

then click on a clip to select it.
2. Click on Auto to have iMovie make automatic 

adjustments for you.
3. Use the sliders to make manual adjustments 

to the exposure, brightness, contrast, and 
saturation. You can also use the histogram to 
adjust the tonal range (dragging the slider 
from the right makes the video brighter by 
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adding white, while dragging from the left 
makes it darker by adding black).

4. Click on Revert to Original if you need to undo 
your changes. 

5. Click on Done to accept your changes.

Trimming
Trimming allows you to remove unwanted frames 
from the beginning or end of a clip. To trim a clip:
1. Hover over the clip with your cursor until the 

trimming control is displayed.
2. Click on the trimming control to dispaly an 

orange bar at the beginning or end of the 
video.

3. Drag on the edge of the orange bar to trim the 
clip. A timecode will appear to let you know 
the number of frames you’re adding or 
removing, as well as the new duration of the 
clip.

Another way to trim a clip is by selecting and 
choosing Edit > Trim... This will display the Trim 
Clip window, showing you the entire clip with your 
selection. The grayed out area of the clip is the 
part that will be trimmed when you click on Done. 
You can adjust the part you’ll keep by dragging on 
the edges of the selection.

Enhancing Audio
To change the volume level of a clip:
1. Click on the Adjust Audio button and 

then click on a clip to select it.
2. Use the Volume slider to adjust the volume 

level of the clip. Check the box next to 
Reduce the volume of other tracks to 
automatically lower the volume of background 
music, audio effects, or any other sound that 
would play at the same time as the selected 
clip (this feature is called “ducking”).  Use the 
Ducking slider to control the amount of 
ducking applied to the other tracks when the 
current track plays back.

3. iMovie ’08 automatically adds fade in and 
fade out effects to your clips. To adjust the 
duration of a fade in or a fade out, click on 
Manual, then use the sliders to change the 
duration.

4. Click on Done to apply your changes, or on 
Revert to Original to undo the volume 
adjustment.

Normalization allows you to match the volume 
levels across several clips. To normalize the 
volume in several clips:

1. Click on the Adjust Audio button and click on 
the first clip to select it.

2. Click on Normalize Clip Volume to set the 
volume of that clip to 100% without distortion.

3. Click on the second clip and click on 
Normalize Clip Volume again to even out the 
volume levels across the two clips.

4. Repeat steps 2 and 3 for any other clips you 
want to normalize and click on Done when 
you’re finished.

5. To undo the normalization, open up the Adjust 
Audio window and choose Undo 
Normalization or Revert to Original.

Adding Video to a Project
To add video to a project:
1. Click on a video clip and select the frame 

range you want to add to the project.
2. Click the Add to Project button in the 

iMovie toolbar (you can also drag the 
source clip from the Event Library into 
the Project Library).

3. Continue selecting video and adding it to your 
project.

4. To change the order of clips in the Project 
Library, drag and drop the clips around until 
they are in the order you want.

To preview your project, use the techniques 
described in the Previewing Source Video section 
above. iMovie automatically saves your project as 
you work. You can undo every change you make 
to the project until you close the project.

Still Images
To add still photos to a project:
1. Click on the Photos button in the toolbar.
2. Choose a photo to add to your project 

and drag it into the Project area.
3. To adjust the Ken Burns effect, which adds 

motion to still images, click on the crop icon in 
the corner of a still image in the Project area. 
The Ken Burns controls will be visible in the 
Viewer.
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4. To change the zoom level at the start of the 
effect, drag the corners of the green Start box 
to resize it. To change the direction of the 
effect, drag the Start box to another area of 
the window. The yellow arrow will let you 
know the direction in which the motion will 
take effect.

5. To change how the effect will end, repeat step  
4 with the red End box.

6. Click on Done to set the effect when you’re 
finished. 

7. To change the duration of a still image, click 
on the Duration icon (visible when you hover 
over the still image in the Project area), enter 
a new time in seconds in the popup window, 
and click on OK. 

8. To change the default duration of still images, 
choose File > Project Properties and use the 
slider to adjust the default duration.

To create a still image from a single frame in your 
video clip, place your playhead on the frame you 
want to use, right-click and choose Add Still 
Frame to Project. The still image will be added to 
the end of your project.

Music and Sound Effects
To add background music to a project:
1. Clcik on the Music and Sound Effects 

button in the toolbar.
2. Click on the disclosure triangle next to 

iTunes or Garageband in the Music and 
Sound Effects browser to see the songs 
available in each of those programs.

3. Choose an iTunes or Garageband song that 
you want to use. Click on the Play button at 
the bottom of the browser to preview it.

4. Drag the song file from the Browser to an 
empty area of the Project area. The song is 
displayed as a green backbround surrounding 
the clips in the project. A music indicator will 
display after the last clip if the music is longer 
than the video.

5. To trim the music so it fits the video, click on 
the green background to select the music and 
choose Edit > Trim Music. This will 
open the Trim Music window which 
shows the waveform that makes 
up the sound file. The pink area of 
the waveform shows where there 

is video. Drag the yellow bars to change the 
start and end points for the music. The video 
will play in the Viewer to help you make this 
adjustment.

6. Click on Done when you’re finished trimming 
the music.

To add a sound effect:
1. Open the Music and Sound Effects Browser 

and click on the disclosure triangle next to 
iMovie ’08 Sound Effects or iLife Sound 
Effects to display the available sound effects.

2. Choose a sound effect and drag it into the 
Project area until it is over a video clip and 
you see the skimming bar. When you find the 
location in the video where you want the 
sound effect to start, release your 
mouse. The sound effect will be 
displayed as a green icon below the 
clips.

3. To trim the sound effect, drag on the edges of 
the icon to resize it. To remove the sound 
effect, click on the icon and press the Delete 
key on your keyboard. 

Voiceovers
To record voiceover narration in iMovie ’08:
1. Click on the Voiceover button in the 

toolbar to open the Voiceover window.
2. Choose a recording device using the Record 

From pulldown menu.
3. Adjust the volume as needed using the Input 

Volume slider.
4. Use the Noise Reduction slider to reduce 

ambient noise in your recording. 
5. When you’re ready to record, click on a clip in 

your project where you want to start your 
voiceover (as marked by the skimming bar). 
iMovie will show a counter to let you get ready 
and a Recording indicator in the Viewer will 
let you know that you’re recording.

6. Press the Space Bar to stop recording. The 
recording will display as a purple icon 
underneath the clip. 

7. To change the duration of the voiceover, click 
on the purple icon to select it and drag on one 
of its edges. To remove the voiceover, select 
the icon and press the Delete key on your 
keyboard.
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8. Close the Voiceover window when you’re 
done recording voiceovers.

Titles
To add a title to your movie:
1. Click on the Titles button in the toolbar. 
2. Choose a title style and drag it over a 

clip in the Project area. 
3. When you hover the clip a portion of the clip 

will be shaded in purple (this will let you know 
how much of the clip will include the title: the 
first third, the entire clip, or just the last third). 
Drop the title into the clip when you see the 
purple shading over the portion of the clip you 
want to use. The title will be added as a blue 
icon over the clip. 

4. To edit the title, make sure the blue title icon 
is selected. A preview of the title will be 
displayed in the Viewer. Click on the 
placeholder text to enter your own text. 

5. Click on the Show Fonts button to open the 
Fonts window where you can change the 
color, size, font family and other properties.

6. Click on Done when you’re done editing your 
title text.

7. To change the duration of the text, click on the 
blue icon and drag on one of its edges (a title 
can span several clips).

To create a title over black, drag a title style from 
the Titles browser and drop it at the beginning or 
end of your project (so it is not over a clip)

Transitions
To add a transition between two clips:
1. Click the Transitions button in the 

toolbar to bring up the Transitions 
browser. 

2. As you hover over a transition in the browser 
the thumbnail will display a preview of what it 
does.

3. When you find a transition you like, drag it 
into the Project area and drop it 
between two clips. The transition 
will display as a black box between 
the two clips.

4. To preview the transition, skim through the 
video beginning with the clip right before the 
transition. To delete a transition, click on the 
black transition marker to select it and press 
the Delete key on your keyboard.

To change the duration of a transition: 
5. Click on a transition to select it and choose 

Edit > Set Duration.
6. Enter the number of seconds you want your 

transition to last in the dialog box.
7. Choose whether you want to apply the 

change to the currently selected transitioin or 
to all transitions in your project.

8. Click on OK.

Sharing
To share your movies with others you have to 
export them out of iMovie using one of the options 
in the Share menu.

To share your movie for use on an iPod, iPhone, 
or Apple TV:
1. Choose Share > iTunes.
2. When the Publish window opens, click on one 

of the sizes (Tiny, Mobile, Medium or Large).  
The blue dots will let you know what devices 
your movie will play on with the size you’ve 
chosen. On the right, you will see the 
dimensioins of your movie in pixels.

3. When you are ready to export, click on 
Publish. After a short wait (depending on your 
movie length and the speed of your computer) 
the movie should open in iTunes so you can 
play it.

The other options in the Share menu work in a 
similar way and are as follows:
• Media Browser: will make the movie available to 

other programs such as iWeb or iDVD. To 
access the movie in one of those programs, 
click on the Media button in that program . This 
option will also place a copy of the exported 
movie in the Project Library in iMovie.

• YouTube: this option will allow you to log into 
your YouTube account so you can upload the 
movie in the correct size for that website. You 
can also add tags (the same as keywords) and 
a description.

• .Mac Web Gallery: allows you to log into 
your .Mac account where you have up to 10GB 
of space to store your movies.

For each of these exporting options, you have the 
option of removing the movie. With YouTube 
and .Mac this will delete the movie so it’s no 
longer available online. To access more advanced 
options (such as custom compression settings) 
choose Share > Export Using Quicktime. 
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