
 

 

InspireData is a visual learning tool that allows students to easily collect and analyze data using 
multiple plot types. Students can then see relationships and connections they may have missed 
by only looking at the data in a spreadsheet or database. InspireData’s Time Series animation 
feature allows students to see how data changes over time, helping them understand trends. 
The Slide Show feature makes it easy to share results and conclusions with the rest of the 
class. The program includes 50+ database templates to help students quickly get started with 
their data analysis projects.  

Creating a New Project
To create a new project:
1. Launch InspireData by clicking on 

the program’s icon. 
2. Choose New when the InspireData 

Starter opens. 
3. The program will open up in Table 

View. Each row in Table View is a record, 
and each column is a field that can hold a 
value. For example, one of the fields can 
be Student Name and it can have a value 
of Tom or Judy.

4. To enter data in any of the cells click on it 
and begin typing, then press Return or 
Enter on your keyboard.

5. To save your project, choose File > Save 
and enter a name for your project, then 
click on Save.

InspireData includes more than 50 curriculum 
based projects to help you get started. To 
open one of these projects, choose 
Databases from the InspireData Starter 
when you launch the program or 
choose File > Open Database.

Working in Table View
InspireData opens in Table View by default 
when you create a new project. In Table 
View, you can do the following:
• Change the name of a field: click on the 

field name and enter a new name, such as 
age, etc.

• Change the icon for a record: double-
click on the symbol to the left of a 

record to open the Icon Editor. To use a 
student photo as the record icon, click on 
Import in the Icon Editor and locate the 
photo you want to use, then click on Open.

• Add a record: click on the Add Record 
button in the toolbar to add a record 
with the default icon.

•  Add a field: click on the Add Field 
button in the toolbar. To delete a field, 
right-click on it and choose Delete Field.

• Change field order: click on the field name 
and drag and drop until it is where you want 
it.

• Sort field values: choose Table > Sort. 
Choose the field you want to sort by and 
whether it should be in ascending or 
descending order, then click on OK to close 
the dialog box.

• Change the data type of a field: click on the 
field name to display the data type 
pulldown menu, then select a data type.

• Add a note to a cell: select the cell and 
click on the Note button. Enter the note 
text in the text area above the table 
cells and click on the Note button again to 
hide the note. A triangle will appear on the 
upper right corner of the cell to let you 
know it has a note. To edit the note, click on 
the Note button with the cell selected.
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Surveys
A survey is a data entry form that can make it 
easier to enter data accurately. Using the e-
Survey feature introduced with version 1.5 of 
InspireData, you can publish surveys to the 
Web so that the data can be entered from 
any computer connected to the internet. 

Each database has a survey associated with 
it by default. To edit the survey and 
customize it to fit your needs:
1. Choose Table > Edit Survey.
2. Click on Use custom title to add a title to 

the survey.
3. Check the box next to Allow user to select 

record icons if you want students to select 
their own icons.

4. Check the boxes for the fields you want to 
include. Check the Required? box for any 
field that cannot be left blank.

5. If you’re using the survey as an e-Survey, 
use the Invitation field to explain what the 
survey is about.

6. Enter the text for your questions in the 
Question text boxes.

7. Click on OK.

To use the survey to enter your data, choose 
Table > Launch Survey. For each record, 
enter the data in the appropriate fields and 
click on the Add Record button.


To publish the survey so your students can fill 
it out online:
1. Choose Table > Publish e-Survey.
2. Click on Publish.
3. The next screen will show you the URL 

where the survey can be accessed 
online, as well as some important ID 
numbers. The Survey ID will be needed 
by your students to fill out the survey, 
while the Owner ID will be required by 
you to end the e-Survey. You may want to 
print out the information on this screen by 
clicking on Print This Text.

4. Click on Done to close the window.

To fill out the e-Survey, your students will go 
to http://esurvey.inspiredata.com, enter the 

Survey ID and click on Start. They will click 
on Submit when they’re finished to save the 
data to the e-Survey database. 

To end an e-Survey so that no more entries 
can be made, choose File > End e-Survey, 
enter the Owner ID and click on End e-
Survey. You will be asked to confirm that you 
want to end the e-Survey. 

There are two ways to view the survey 
results:
• choose e-Survey from the Starter, enter the 

Survey ID and click on Open.
• choose File > Open e-Survey Database. 

Plot View
To work in Plot View:
1. Click on the Plot View button in the 

toolbar. The data is displayed freely 
the first time you switch to Plot View. 
Each icon represents a record in your 
database.

2. To view the data for any record in your 
data set, double-click or hover over its 
icon. The record’s data will be displayed 
in a popup window. To close the window, 
click anywhere on the plot.

3. To change the plot type, click on one of 
the plot type buttons in the toolbar at the 
bottom of the window.

4. To clear a plot to its default settings, 
click on the Clear button in the 
toolbar.

5. InspireData keeps a history of the plots 
you create. To go back to a previous plot, 
click on the Back button in the toolbar just 
as you would on a web browser. Click the 
Forward button to return to the most 
recent plot.

6. To return to Table View, click on the 
Table View button in the upper left.

You can change the appearance of a plot in a 
number of ways:
• Turn on labels: click on the Label 

button. To change the field used for 
the labels, click on the down arrow next to 
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the Label button and choose a different 
field.

• Add color to your icons: click on the 
Color by Field button and select a 
field. A legend will be added at the top of 
the plot.

• Change the icon size: click on the icon 
size button and use the slider to adjust 
the size.

• Mark (highlight) an icon: click on the 
icon to select it, then click on the Mark 
button in the toolbar.

• Add a plot title: choose Plot > Plot Title. 
Enter a title and click on the Accept button 
(it looks like a check mark).

• Add a note: click on the Note button and 
enter the text for the note. Click on the Note 
button again to hide the note.

Venn Plot
A Venn plot divides the data into groups 
based on certain characteristics. A Venn 
diagram can have up to three loops in 
InspireData.
To create a new Venn plot:
1. Click on the Venn Plot button in the 

toolbar.
2. Click on the word Field and choose a 

field.
3. Click on the equal sign and choose an 

operator.
4. Click on the question mark. Enter a value 

in the popup window to restrict your data 
using that value and click on the Accept 
button (it looks like a checkmark). For 
example, you may want to only dispaly 
students whose age is < 10.

5. Click on the Add Loop button if you 
need multiple groups. To delete a 
loop, click on the square at the start 
of the loop. 

Stack Plot
A stack plot is useful for displaying counts of 
items. A stack plot divides a field into 
categories and organizes the icons in each 
category into a stack. The more records a 

category has, the higher the stack.

To add a stack plot:
1. Click on the Stack Plot button in the 

toolbar.
2. Click on X Axis and select a field. The 

icons will display as stacks.
3. To change the type of stack plot, click on 

the Stack plot type button in the lower left 
and choose a different stack plot type. 

4. Use the button to the right of the Stack 
plot type button to switch between a stack 
plot and a bar chart. 

Axis Plot
An axis plot shows a scatter graph that is 
helpful for investigating correlations. 

To create a new axis plot:
1. Click on the Axis Plot button in the 

toolbar.
2. Click on X Axis and choose a field for that 

axis.
3. Click on Y Axis and choose a field for that 

axis.

Pie Plot
A pie plot is useful for showing how a group 
of data are related to the whole data set. 

To create a new pie plot: 
1. Click on the Pie Plot button in the 

toolbar.
2. Click on the Select Field button at the top 

of the plot and choose a field.
3. If you want to compare two pie plots side 

by side, click on the Plot type button in 
the lower left and choose a type with 
multiple pie plots. Next, click on X Axis or 
Y Axis and choose the field you want to 
use for the comparison.

Time Series Data
InspireData can create animations showing 
how data changes over time, also known as 
time series data. To create a time series plot, 
you will first need at least one field in your 
table to have the Series type assigned to it.
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To create a Series field in Table View: 
1. Create a new field in your table by 

clicking on the Add Field button.
2. With the new field selected, choose 

Series from the field type pulldown menu. 
The Series Field window will open.

3. Choose the format of the column 
headings and the data type of the cells in 
the series.

4. Click OK when you’ve set your options to 
close the Series Field window. 

To create a new time series plot:
1. Create a new Axis plot by clicking on the 

Axis plot button in the toolbar.
2. Click on the Series Plot button in the 

lower left corner and then choose 
Instant Plot.

3. Series Playback controls will be displayed 
above the plot. Use these controls to 
animate the time graph.

4. By default every record is displayed 
individually. To group records, click on the 
Series Plot type button and choose 
Grouping, then choose the field you want 
to use to group the data. 

Calculations
To calculate summary data for a plot:
1. Click on Compute summary data 

button. Questions marks will appear 
on the plot.

2. Click on the Operation button in the 
toolbar and choose the type of calulation 
(mean, media, smallest, largest, count, 
etc.) you want to perform.

3. Click on the Field button and choose the 
field you want to base the calculation on. 
Choose Formula to open a window where 
you can perform more advanced 
calculations.

Slide Shows
The slideshow feature allows students to 
document and present their work. Each slide 
captures a live view of the data, meaning that 

they are updated whenever changes are 
made to the original plots.

To create a slideshow:
1. Click on the Slide Sorter button to 

open the Slide Sorter on the right 
side of the screen.

2. Click on the Capture Slide button 
to add a new slide to the Slide 
Sorter.

3. Continue clicking on the Capture Slide to 
capture additional slides.

Once you have captured your slides, you can 
modify them in a number of ways:
• To rename a slide: click on the 

Slide Options button for that slide 
and choose Rename Slide. Enter 
the new name and click on OK.

• To update a slide after you make changes 
to a plot: click on the Slide Options button 
for that slide and choose Update Slide.

• To reorder slides: drag and drop the slide 
you want to move to a location.

• To delete a slide: choose the slide and 
press the Delete key on your keyboard.

To view your captured plots as a slideshow, 
choose Slide Show > Start Slide Show. 
InspireData will go to the first slide in the 
Slide Sorter and display slide show controls 
you can use to advance to the next slide.

Export Data
To export data so it can be used in another 
program (such as Microsoft Excel), choose 
File > Export Table.  You can choose to have 
the data saved in a comma delimited (.csv) or 
tab delimited (.tab) file. The comma delimited 
option is recommended. 

Keyboard Shortcuts
• Add Record in table view: Control/

Command + R
• Add Field in table view: Control/Command 

+ L
• Capture slide: Control/Command + E

InspireData Basics
 Created by Luis Perez
Page 4 of 4
 Last Updated:6/2/08


